Different colours comparing to the original image

Post any questions about the Smart Photo Editor Software here
Forum rules
You are viewing the Community Help Pages. They are on-line forums where people can come to ask questions about the Smart Photo Editor and all the replies and relevant information are kept in the same place.
Posts: 1
Joined: Sun Nov 13, 2016 12:11 pm

Different colours comparing to the original image

Postby Lioubov Chapman » Sun Nov 13, 2016 12:28 pm

Recently the Smart Photo Editor started to show absolutely different colours comparing to the original image. After loading image from Photoshop CC 2017 into the Smart Editor I see dramatic changes in the colours. My computer is iMac. The same problem I have with another filter "Landscape". As result of this problem I can not use these filters anymore.
I think I just found out the reason: Smart Photo Editor doesn't support a new colour profile ProPhoto RGB in Photoshop CC 2017. Can this problem be resolved?

Posts: 69
Joined: Tue Mar 02, 2010 11:32 am

Re: Different colours comparing to the original image

Postby gary » Tue Nov 15, 2016 3:52 pm

We are looking into this. It does look like the colours are displayed incorrectly when SmartPhotoEditor is used as a Photoshop plugin, but on returning back to Photoshop they are correct.

Posts: 6
Joined: Fri Sep 01, 2017 4:24 pm

Re: Different colours comparing to the original image

Postby huseinlatifphotography » Fri Sep 01, 2017 4:27 pm

Is there a fix for this yet? Im facing the same issue of colors different from the original whenever I open the image in Smart Photo Editor in PS. Im unable to use the software after having bought it not a week ago!!!

Posts: 1
Joined: Wed Jun 17, 2015 12:48 am

Re: Different colours comparing to the original image

Postby orcaspest23 » Sun Sep 03, 2017 2:41 am

I'm having the same problem. It's difficult to fix pictures when they are not displayed properly. :shock: I have Windows 7.

Posts: 69
Joined: Tue Mar 02, 2010 11:32 am

Re: Different colours comparing to the original image

Postby gary » Mon Sep 04, 2017 3:09 pm

This is down to Apple removing the API function for returning the monitor color profile. Now the SmartPhotoEditor software assumes an sRGB monitor when the monitor profile cannot be found. We are looking for a solution to this problem caused by the Apple update.

Posts: 6
Joined: Fri Sep 01, 2017 4:24 pm

Re: Different colours comparing to the original image

Postby huseinlatifphotography » Wed Sep 27, 2017 9:31 am

Im sorry but that is not a very satisfactory answer, having bought this software...the least you expect is that it works in the way it was advertised, else we have a problem! It is unusable in the current condition!

It wasn't exactly advertised that it was not going to work as it should on a Apple/Mac system was it? Someone really needs to get their act together and ensure that people are able to use what they have paid for.

Return to Other Questions About The Software

Who is online

Users browsing this forum: No registered users and 1 guest