Crashes with "Access is denied" error

Any crashes, places where the software didn't work as you expected, please let us know here.
Posts: 12
Joined: Wed Apr 06, 2011 4:20 am

Crashes with "Access is denied" error

Postby jgodfrey » Thu Apr 14, 2011 2:02 am

I just updated to the latest Beta (v0.7.16). Now, when I attempt to apply an effect, I get a crash with the following message:

ZWin32ErrorException: Error 0x00000005 with file 'C:\Users\Jeff\Documents\PhotoEditor\forupload\xupd.tag', Access is denied.

Looking in the mentioned folder, there is a current "xupd.tag" file (created 2 minutes ago). Also, there is a xpop.tag file there. There aren't any particular permission problems on the folder, so if something has the files in question tied up, I'd guess it's SPE itself.

While I had plenty of crashes prior to this update, I never saw this one. I really can't use the app at all now.

Thoughts?

Jeff

Site Admin
Posts: 2406
Joined: Thu Feb 25, 2010 7:11 pm

Re: Crashes with "Access is denied" error

Postby admin » Thu Apr 14, 2011 9:38 am

I think a reboot should fix that. If not let me know, as it's certainly something we can fix. Either way, I'll make it so it doesn't crash if those files are in use.

We fixed a whole bunch of bugs since 0.7.14, so it will be interesting to hear if it is more stable now. (present bug excepted)!

Tony

Posts: 12
Joined: Wed Apr 06, 2011 4:20 am

Re: Crashes with "Access is denied" error

Postby jgodfrey » Thu Apr 14, 2011 2:28 pm

admin wrote:I think a reboot should fix that. If not let me know, as it's certainly something we can fix.

In my case, a reboot does not fix the issue. I just rebooted again to make sure. Same crash after applying the first effect.

Jeff

Site Admin
Posts: 2406
Joined: Thu Feb 25, 2010 7:11 pm

Re: Crashes with "Access is denied" error

Postby admin » Thu Apr 14, 2011 5:52 pm

Are you logged in as the same user that installed the software?

Tony

Posts: 12
Joined: Wed Apr 06, 2011 4:20 am

Re: Crashes with "Access is denied" error

Postby jgodfrey » Thu Apr 14, 2011 8:50 pm

admin wrote:Are you logged in as the same user that installed the software?

Yep, there's only one account on this system - and it has Admin privileges.

Jeff

Posts: 12
Joined: Wed Apr 06, 2011 4:20 am

Re: Crashes with "Access is denied" error

Postby jgodfrey » Thu Apr 14, 2011 8:53 pm

In addition to my response immediately above, I just tried this again...

The software instantly crashes with the mentioned error when I apply the first effect. If I go to the folder in question immediately after the crash both mentioned files are there and have a current time stamp. I can open, rename, and delete the files at will, so they don't seem to have any legitimate permission problems.

Jeff

Posts: 12
Joined: Wed Apr 06, 2011 4:20 am

Re: Crashes with "Access is denied" error

Postby jgodfrey » Fri Apr 15, 2011 2:07 am

In addition to my previous responses...

I've played with this some more and it doesn't happen *every* time - just most of the time. On about 10% of my attempts, I don't get the access denied crash when applying the first effect. But, if it doesn't happen on the first one, it's almost guaranteed to happen on the second.

Jeff

Posts: 12
Joined: Wed Apr 06, 2011 4:20 am

Re: Crashes with "Access is denied" error

Postby jgodfrey » Mon Jun 13, 2011 7:52 pm

Just curious when another beta build will become available? As reported in this tread, the app has been completely unusable for me for more than 2 months now due to the "access denied" error. A comment was made in this thread that the crash would be fixed, but that was nearly 2 months ago.

In addition, there seems to be very little recent activity in this entire forum...

Jeff

Posts: 4
Joined: Mon Apr 04, 2011 7:21 am

Re: Crashes with "Access is denied" error

Postby nmackenz » Fri Jun 24, 2011 1:48 pm

Jeff

Interestingly enough I have the same concern and question that you have - where is the new updated release and why is the forum so quiet? Interestingly enough I came across the Smart Photo Editor website today, and it seems that there is now a full software package for sale, I guess we as beta testers were not informed of this fact. Also thought that it was said that if you become a beta tester that you would receive the final product for free - guess that is not the case.

It's a shame...

Nelmari

Site Admin
Posts: 2406
Joined: Thu Feb 25, 2010 7:11 pm

Re: Crashes with "Access is denied" error

Postby admin » Mon Jun 27, 2011 4:05 pm

To answer your questions:

Yes, we're trying some test marketing campaigns with an on sale version. Beta users weren't notified because we didn't want to skew our sales with a biased audience, I guess the cat's out of the bag now!

We are going to release a new beta version soon, which includes a bunch of bug fixes, and several other changes.

Any beta users who have given feedback will be given a free copy of the full version once it is out of beta.

As for why the forum is quiet, well that is up to you guys, but the beta is fairly small, and I guess people who had anything to say have said it!

Tony

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest